Definite Clause Deduction

Back to help contents.

dot Creating A Knowledge Base

There are two ways to create a problem in the Definite Clause Deduction Applet.

  1. Load A Sample Knowledge Base

    This is the way to load an existing knowledge base. You can load from a set of sample problems, or load from a URL.

    • On the menu bar, select File->Load Sample Knowledge Base. A dialog will pop up with a choice of sample problems. Choose one.

    • On the menu bar, select File->Open Location. Type in the URL of the knowledge base, and click load.

  2. Create a knowledge base manually

    Click the Create mode tab to display the Create panel. Type in the knowledge base into the text area in CILog format.

dot Solving A Problem

Click the Solve mode tab to go to Solve mode. Click the Create New Query button and select a predicate. A dialog will pop up that will prompt the user to input the terms that are needed to be queried. Click ok to go back to Solve mode. The query will now be displayed on the canvas.

There are three ways to solve a query.

  1. Click the Step button. This will do a single unification step.

  2. Click the Fine Step button. This will do an incremental step.

  3. Click the Auto Search button. This will do unification until the first solution is found, or until all the branches of the solution tree have been unified.

It is also possible to use algorithms other SLD resolution (depth first), or even to solve the query manually. To do this, click Deduction Options -> Deduction Algorithms, and select an algorithm. Selecting "User Defined" means that in order to unify a query, the user should select the Step button, and click on the node that he or she wants to unify.

Back to help contents.

Valid HTML 4.0 Transitional