How are the class names in this ontology misleading? How would you rename the classes to make them less misleading?
- All of the subclasses of "PizzaTopping" have misleading names. For example, according to the ontology all fruits are pizza toppings. However, this is somewhat different from the standard definition of pizza toppings. A better name for the subclasses would be to append "PizzaTopping" to each class name. For example, "meat" becomes "meatPizzaTopping", "fruit" becomes "fruitPizzaTopping" and "tomato" becomes "tomatoPizzaTopping".